서브메뉴

트위터 플러그인 OAuth인증 업데이트

by J.Parker

트위터에서 OAuth인증만 허용한다는 소식이 며칠 전에 있었습니다. 하여 기존 배포된 트위터 플러그인을 OAuth인증을 할 수 있도록 업데이트 했습니다.

기존 배포된 트위터 플러그인은 버리시고 다시 다운로드 받으신 후 플러그인 환경설정에서 OAuth인증을 진행하시고, 설정 저장을 하시면 문제없이 사용하실 수 있을 겁니다.

사용 환경

  • PHP5 이상, 텍스트큐브 1.8.3 이상 추천. (1.8 이하 버전 지원 불가)
  • OAuth인증을 위해 서버에 CURL라이브러리가 설치되어 있어야 합니다. CURL 설치 관련 사항은 서버 관리자(호스팅 회사)에 문의해보시기 바랍니다.
  • CURL라이브러리가 설치되어 있더라도 일부 서버 환경에 따라 다소 처리 속도가 느릴 수 있습니다. 이점 양해 부탁드립니다.

다운로드

개선사항

  • OAuth인증
  • 사이드 정보 캐시처리 : 페이지 로딩시 API 처리를 감소시킴 1일 단위 캐시 클리어 됩니다.
    (블로그에서 페이지캐시를 사용해야 함..)
  • 저장된 'Lists' 목록을 사이드에 출력.

환경설정

OAuth 인증 전

OAuth 인증 전

OAuth 인증 후

OAuth 인증 후


수정사항

  • 일부 스크립트 버그 수정.
  • 짧은 URL bit.ly외 j.mp, goo.gl, is.gd 환경 설정에서 선택 지정.
  • 이미지 링크 미리보기 기능 추가.
  • 답변 트윗 목록 보기 기능 추가.
  • 트위터로 글 보낼 때 글 링크를 블로그 URL/짧은 URL 선택할 수 있게 보완.



2010/09/08 10:59 2010/09/08 10:59
Rated 4.71/5 (94.29%) (7 Votes)
받은 트랙백이 없고   4개의 댓글이 있습니다.
이 글의 댓글/트랙백 RSS : http://www.textcube.org/plugin/rss/response/759
이 글의 관련글(트랙백) 주소 : http://www.textcube.org/plugin/trackback/759